High response time on Address Validate V2 REST and Experian Address Validate

Incident Report for Experian Data Quality

Resolved

Performance is stable - we continue to monitor closely.
Posted Nov 05, 2025 - 09:55 UTC

Update

We are continuing to investigate this issue.
Posted Nov 05, 2025 - 08:59 UTC

Investigating

Some customers in UK region may have seen higher response times for a short period - response times are now normal - we are investigating.
Posted Nov 05, 2025 - 08:47 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).