Network Connectivity in McKinney Datacenter ( Email Validate RT )
Incident Report for Experian Data Quality
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 17:25 UTC
Investigating
We are currently investigating this issue.
Posted Aug 09, 2022 - 15:53 UTC
This incident affected: Email Solutions (Email Validation, Experian Email Validation).