Email Validate Real Time service is temporarily unavailable
Incident Report for Experian Data Quality
Resolved
Services have been recovered, investigation into the root cause is ongoing
Posted Mar 14, 2021 - 13:03 UTC
Investigating
We're currently experiencing a service outage. Due to connectivity / network issue in the datacenter, Email Validate is currently unavailable. This is being investigated as a top priority
Posted Mar 14, 2021 - 11:28 UTC
This incident affected: Email Solutions (Email Validation).