Slow response in US datacentre
Incident Report for Experian Data Quality
Resolved
Happens only between 1550 and 1610 UTC. The service is now responding normally, and we are monitoring closely.
Posted Apr 22, 2024 - 20:01 UTC
Investigating
Some customers using these services may have seen higher response times than normal for a period of time.
Posted Apr 22, 2024 - 19:49 UTC
This incident affected: Address Solutions (Experian Address Validation).