There is a known issue on the sign-in page for EDQ SaaS Portal & Online Community
Incident Report for Experian Data Quality
Resolved
resolved after Incapsula disabled the JS classification mechanism challenges on the required resources
Posted 14 days ago. Oct 03, 2019 - 07:42 UTC
Identified
We are aware that some users are experiencing issues when logging in. We apologize for any inconvenience caused and will aim to get this resolved quickly. As a temporary workaround, please refresh this page by clicking CTRL+F5 or clear your cache.
Posted 21 days ago. Sep 26, 2019 - 09:55 UTC
This incident affected: Self Service Portal.