Automated Batch Email Validation

Incident Report for Experian Data Quality

Resolved

Between 0700UTC and 1000UTC customers may have experienced errors when uploading EV Batches. If you were impacted, please re-upload your batch, and it should process as normal. We apologise for any inconvenience caused.
Posted Oct 08, 2024 - 10:24 UTC

Investigating

We are currently investigating on this issue
Posted Oct 08, 2024 - 07:00 UTC
This incident affected: Email Solutions (Email Validation, Automated Batch Email Validation).