Hosted Aperture Data Studio AU1 Slow Workflow Execution.

Incident Report for Experian Data Quality

Monitoring

Performance has been restored and we are actively monitoring it.
Posted May 04, 2026 - 08:21 UTC

Investigating

We're currently experiencing slow workflow execution. We're currently working on identifying the cause and will update as soon as possible.

We apologize for any inconvenience caused.
Posted May 04, 2026 - 07:30 UTC
This incident affects: Hosted Aperture Data Studio (Australia [AU1]).