UK phone number validations that include landline checks are timing out (error code 408)

Incident Report for Experian Data Quality

Resolved

This incident has been resolved, service is now operating normally.
Posted Jun 18, 2026 - 11:30 UTC

Investigating

Customers trying to validate UK phone numbers might be experiencing slow responses or receiving timed-out results. The investigation is ongoing.
Posted Jun 18, 2026 - 07:57 UTC
This incident affected: Phone Solutions (Experian Phone Validation).