Performance Degraded - Email Validate Services

Incident Report for Experian Data Quality

Resolved

Connectivity is stable, and we are monitoring closely
Posted Apr 08, 2025 - 09:47 UTC

Investigating

Customers may have experienced connection issues for a short period with Email Validate services, and we are investigating.
Posted Apr 08, 2025 - 05:37 UTC
This incident affected: Email Solutions (Email Validation, Experian Email Validation, Automated Batch Email Validation).