Email Validation high response times

Incident Report for Experian Data Quality

Resolved

Response times are now back to normal levels, we are monitoring closely.
Posted Dec 17, 2024 - 22:15 UTC

Update

Ops team able to see improvement in response times for Email validation. Investigation is still ongoing.
Posted Dec 17, 2024 - 17:59 UTC

Investigating

We are seeing higher than normal response times for Email validation, and engineering teams are investigating.
Posted Dec 17, 2024 - 09:51 UTC
This incident affected: Email Solutions (Email Validation, Experian Email Validation).