Self Service Portal is not accessible intermittently

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Dec 05, 2024 - 08:10 UTC

Update

The issue is still being investigated by Microsoft.
Posted Dec 05, 2024 - 06:25 UTC

Update

Issue is being investigated by Microsoft.
Posted Dec 05, 2024 - 03:06 UTC

Investigating

Issue is being investigated by Microsoft.
Posted Dec 05, 2024 - 03:02 UTC
This incident affected: Other (Self Service Portal).