Email Validation ( Batch and RT ) - Performance degraded

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 04:31 UTC

Monitoring

We already did a failover to the secondary site and processing is on-going normally. We are monitoring
Posted Apr 29, 2025 - 04:04 UTC

Investigating

Clients would have received increased unknown results.
Posted Apr 29, 2025 - 03:43 UTC
This incident affected: Email Solutions (Email Validation, Experian Email Validation, Automated Batch Email Validation).