Multiple EDQ products performance degraded

Incident Report for Experian Data Quality

Resolved

This incident has been resolved. We are still monitoring performance closely.
Posted Oct 30, 2025 - 09:54 UTC

Update

We continue to monitor the situation closely
Posted Oct 29, 2025 - 22:39 UTC

Update

We are still monitoring performance of the applications.
Posted Oct 29, 2025 - 21:31 UTC

Update

We continue to monitor services closely.
Posted Oct 29, 2025 - 19:46 UTC

Monitoring

The issues on the impacted products has been mitigated for now and we are monitoring closely.
Posted Oct 29, 2025 - 17:46 UTC

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 16:48 UTC

Investigating

We're currently experiencing a degraded performance for multiple products , our team is currently investigating.
Posted Oct 29, 2025 - 16:31 UTC
This incident affected: Email Solutions (Email Validation, Experian Email Validation), Phone Solutions (Phone Validation, Experian Phone Validation), and Address Solutions (Experian Address Validation, Address Validation (REST v2)).