High response time on Address Validate V2 REST and Experian Address Validate

Incident Report for Experian Data Quality

Resolved

Services are running normally now - we are monitoring closely.
Posted Nov 06, 2025 - 20:34 UTC

Monitoring

Customers should be seeing improved performance - Team still investigating
Posted Nov 06, 2025 - 19:20 UTC

Investigating

We are currently investigating this issue.
Posted Nov 06, 2025 - 17:57 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).