Address validation - Elevated Response Times and Intermittent Errors

Incident Report for Experian Data Quality

Resolved

This incident has been resolved
Posted Apr 23, 2026 - 05:30 UTC

Investigating

Some users maybe have experienced elevated response times and related errors.
Posted Apr 23, 2026 - 04:45 UTC
This incident affected: Address Solutions (Experian Address Validation).