P2 : Address Standardization/Experain Certificate Issue
Incident Report for Experian Data Quality
Resolved
Fix has been implemented, and we are monitoring closely.
Posted Feb 09, 2022 - 22:04 UTC
Investigating
Impacting some customers may have had connectivity issues and that we are investigating.
Posted Feb 09, 2022 - 21:57 UTC
This incident affected: Email Solutions (Email Validation), Phone Solutions (Phone Validation), and Address Solutions (Address Validation (REST v1)).