Degraded performance on Address Validation (REST v2) and Experian Address Validation

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Dec 09, 2024 - 09:06 UTC

Investigating

Some customers using the Experian address validation products may have seen intermittent higher latency for a period of time(9th December 2024 0300 - 0315 UTC).
Posted Dec 09, 2024 - 09:06 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).