EDQ.com intermittently down
Incident Report for Experian Data Quality
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 11, 2019 - 15:27 UTC
Investigating
EDQ.com is intermittently timing out. We are currently investigating the issue.
Posted 6 months ago. Jan 11, 2019 - 14:38 UTC
This incident affected: EDQ.com.