High response time for Address Validate REST v2 and Experian Address Validate

Incident Report for Experian Data Quality

Resolved

Performance issues with format requests have been fixed, and performance is back to normal levels - we are monitoring closely.
Posted Nov 28, 2025 - 17:17 UTC

Investigating

Some customers in North America may be seeing higher response times. We are investigating with priority.
Posted Nov 28, 2025 - 16:51 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).