Correct Address and IST Timeout
Incident Report for Experian Data Quality
Resolved
We are still investigating / monitoring closely.
Posted Jan 27, 2022 - 22:40 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 27, 2022 - 21:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 27, 2022 - 20:43 UTC
This incident affected: Other (IST Watch).