Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 01, 2024 - 07:00 UTC
Scheduled
Please note that we are planning essential maintenance to Email Automated Batch. During this maintenance there will be a short period where you may not be able to upload or download files.
We apologize for any inconvenience this may cause.
Please reach out to your local support teams if there are any questions
Posted Sep 30, 2024 - 12:57 UTC
This scheduled maintenance affected: Email Solutions (Automated Batch Email Validation).