Incident Notification - P2 - Electronic Updates DB issue - Open
Incident Report for Experian Data Quality
Resolved
The issue has been identified and a fix has been implemented. This incident has been resolved.
Posted Nov 14, 2020 - 17:44 UTC
Investigating
We are currently investigating this incident.
Posted Nov 14, 2020 - 17:08 UTC
This incident affected: Other (Electronic Updates).