EV higher than normal undeliverable rates
Incident Report for Experian Data Quality
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 07:30 UTC
Update
We are still investigating the root cause and fix, and apologies for any inconvenience
Posted Apr 04, 2024 - 16:19 UTC
Investigating
We are currently experiencing a some issues with "confidence levels". Some customers may see higher undeliverable rates for some domains. We are investigating this as a matter of urgency
Posted Apr 04, 2024 - 14:49 UTC
This incident affected: Email Solutions (Email Validation, Experian Email Validation, Automated Batch Email Validation).