Incident Notification - P2 - High response time for GI UK

Incident Report for Experian Data Quality

Resolved

The issue is now fixed. We apologies for any inconvenience this may have caused.
Posted May 19, 2025 - 15:31 UTC

Investigating

Some customers in the UK may have experienced some higher than normal response times.
Posted May 19, 2025 - 15:30 UTC
This incident affected: Address Solutions (Address Validation (REST v2)).