Degraded performance on Experian Address Validate for AU region

Incident Report for Experian Data Quality

Resolved

The issue is now fixed. We apologies for any inconvenience this may have caused.
Posted Jun 27, 2025 - 10:21 UTC

Investigating

some customers might be experiencing higher response times - we are investigating
Posted Jun 27, 2025 - 08:12 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (SOAP)).