Email Validation Batch - Performance degraded

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Oct 14, 2024 - 08:03 UTC

Update

We are continuing to investigate this issue.
Posted Oct 14, 2024 - 07:57 UTC

Investigating

Starting at 2000hrs UTC on the 13th October 2024, some customers may have experienced errors when uploading/downloading EV Batches. We are currently investigating this issue.
Posted Oct 14, 2024 - 07:56 UTC
This incident affected: Email Solutions (Automated Batch Email Validation).