Global Intuitive and Experian Address Validate Latency Issue in UK DC
Incident Report for Experian Data Quality
Resolved
This incident has been resolved.
Posted Nov 19, 2023 - 22:44 UTC
Investigating
We are currently investigating this issue.
Posted Nov 19, 2023 - 21:05 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).