Higher response times on ANZ region for Address Validation (REST v2) & EAV

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 00:20 UTC

Investigating

We are currently investigating this issue.
Posted Mar 24, 2026 - 23:42 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).