Global Intuitive and Experian Address Validate Latency Issue in UK DC

Incident Report for Experian Data Quality

Resolved

Service has stabilized. We will be monitoring closely.
Posted Nov 17, 2023 - 13:51 UTC

Update

We are continuing to investigate this issue.
Posted Nov 17, 2023 - 12:18 UTC

Investigating

We are currently investigating this issue.
Posted Nov 17, 2023 - 12:14 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).