Address Validate & Capture APP issues
Incident Report for Experian Data Quality
Resolved
Fix has been implemented, and we are monitoring closely.
Posted Mar 31, 2022 - 07:19 UTC
Update
We are still investigating on the issue
Posted Mar 31, 2022 - 05:30 UTC
Investigating
We are currently investigating this issue.
Posted Mar 31, 2022 - 00:15 UTC
This incident affected: Address Solutions (Experian Address Validation, Capture Application).