Degraded performance on Address Validate REST v2

Incident Report for Experian Data Quality

Resolved

Response times returned to normal - Operations team are monitoring closely.
Posted Sep 10, 2025 - 16:40 UTC

Investigating

Some customers in US region may be seeing intermittent response time spikes
Posted Sep 10, 2025 - 14:45 UTC
This incident affected: Address Solutions (Address Validation (REST v2)).