Automated Batch Email Validation Degradation

Incident Report for Experian Data Quality

Resolved

We have tuned the platform and are now seeing improved throughput. We will continue to monitor closely
Posted Mar 22, 2025 - 17:55 UTC

Identified

Email Validate batches are processing, but at slower throughput speeds. We are working to improve this situation. Apologies for any ongoing inconvenience
Posted Mar 22, 2025 - 10:30 UTC

Update

The Email Validate Batch platform is currently experiencing slightly reduced throughput speeds for some customer batches. We are continuing to work on this issue, and will provide updates as we have them. Apologies for any inconvenience this may cause.
Posted Mar 21, 2025 - 22:51 UTC

Update

Customers may still be experiencing intermittent connectivity issues - we apologize for any inconvenience, and continue to investigate
Posted Mar 21, 2025 - 20:47 UTC

Investigating

Some customers may be having connectivity issues to Automated Batch Email Validation - we are currently investigating
Posted Mar 21, 2025 - 17:32 UTC
This incident affected: Email Solutions (Automated Batch Email Validation).