Issues with ticket system

Incident Report for Experian Data Quality

Resolved

The issue has been resolved
Posted Dec 16, 2024 - 10:32 UTC

Update

Our third party provider is still working on a permanent fix.
Please remain tuned.
Posted Dec 16, 2024 - 04:29 UTC

Investigating

Dear customer,

Our 3rd party ticketing solution is experiencing an issue, hence, if you are contacting us by email, we may not be receiving your request.

In order to log your request, please call us at:
US: (888) 712-3332
UK: 0207 498 7788
Australia and New Zealand: Call: +61 (0) 3 8622 1655 (Melbourne) or +61 (0) 2 8907 7272 (Sydney).

Thanks.
Posted Dec 13, 2024 - 18:46 UTC
This incident affected: Other (EDQ.com).