Prospect IQ service performance degradation
Incident Report for Experian Data Quality
Resolved
This incident has been resolved.
Posted Sep 17, 2020 - 17:31 UTC
Investigating
Experian is currently investigating on the issue.
Posted Sep 17, 2020 - 17:12 UTC
This incident affected: Enrichment Solutions (Prospect IQ).