Incident Notification - P2 - Degraded performance on Experian Address Validate - Open

Incident Report for Experian Data Quality

Resolved

This incident is now resolved. The issue is no longer happening.
Further investigation to root cause is on-going.
Posted Jul 30, 2025 - 05:19 UTC

Investigating

We are currently investigating the issue.
Some customers may be receiving intermittent errors.
Posted Jul 30, 2025 - 03:12 UTC
This incident affected: Address Solutions (Experian Address Validation).