Performance Degraded - Experian Address Validate (EAV) and Address Validation (REST v2)

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 03:59 UTC

Monitoring

Some customers may have seen higher response times or failures from 11:10am GMT. We are monitoring this closely.
Posted Mar 25, 2025 - 15:41 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).