Address Validate REST v2 and EAV performance degradation (AUS)

Incident Report for Experian Data Quality

Resolved

Response times and errors rates have returned to normal, we are monitoring closely
Posted Jul 10, 2026 - 09:21 UTC

Investigating

Some customers in Australia region may be experiencing elevated response times and error rates. We are investigating.
Posted Jul 10, 2026 - 07:17 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).