Email Validation Batch - Performance degraded
Incident Report for Experian Data Quality
Resolved
This issue is fixed, and we are monitoring closely.
Posted Apr 25, 2024 - 11:50 UTC
Identified
The issue have been identified and a fix is being implemented.
Posted Apr 16, 2024 - 00:46 UTC
Update
We are continuing to investigate this issue.
Posted Apr 13, 2024 - 00:07 UTC
Investigating
We're experiencing temporary issues with Automated Batch Email Validation, so you might experience slowness when using it. We're investigating the issue.
Posted Apr 12, 2024 - 16:03 UTC
This incident affected: Email Solutions (Automated Batch Email Validation).