Experian Address Validate and Address Validate (REST v2) High Response times

Incident Report for Experian Data Quality

Resolved

The service response time is now stable - we are monitoring closely.
Posted Feb 06, 2026 - 10:20 UTC

Investigating

Some customers in ANZ region may be seeing higher response times. We are investigating
Posted Feb 06, 2026 - 09:23 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).