Degraded performance on Experian Address Validate and Global Intuitive (GI)

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 14:20 UTC

Investigating

Some customers in the UK may have seen higher response times intermittently. We are investigating
Posted Sep 15, 2025 - 13:30 UTC
This incident affected: Address Solutions (Experian Address Validation, Address Validation (REST v2)).