Phone Validate Availability Degradation
Incident Report for Experian Data Quality
Resolved
This incident has been resolved.
Posted Nov 25, 2019 - 05:36 UTC
Investigating
Support team has been engaged as well as service provider. Investigations is in progress.
Posted Nov 25, 2019 - 02:59 UTC
This incident affected: Phone Solutions (Phone Validation).