Saas Portal inaccessible

Incident Report for Experian Data Quality

Resolved

This incident has been resolved
Posted Nov 27, 2023 - 12:07 UTC

Investigating

We are currently investigating this issue.
Posted Nov 27, 2023 - 11:30 UTC
This incident affected: Other (Self Service Portal).