High response time on EDQ Address Validate Restv2

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 10:24 UTC

Identified

Some client might have experienced higher response times.
Posted Aug 26, 2026 - 10:24 UTC
This incident affected: Address Solutions (Address Validation (REST v2)).