Email Validate Batch & Real Time - Site intermittently unavailable
Incident Report for Experian Data Quality
Resolved
We've resolved the issues with the service and it's now back to normal. We're now analysing the causes to ensure we continue delivering the best possible levels of service.
Posted Apr 28, 2020 - 07:27 UTC
Investigating
We're experiencing temporary issues with Email Validate Batch and Real TIme, so you might experience issues accessing it. We're investigating the issue and will provide an update by 0730hrs UTC.
Posted Apr 28, 2020 - 06:53 UTC
This incident affected: Email Solutions (Email Validation, Automated Batch Email Validation).