High Response Time for EAV in UK region

Incident Report for Experian Data Quality

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 11:43 UTC

Monitoring

Customers may have seen higher response times. We are monitoring the situation closely.
Posted Oct 15, 2025 - 08:54 UTC
This incident affected: Address Solutions (Experian Address Validation).