Address Validate V2 REST - performance degraded for US region
Incident Report for Experian Data Quality
Resolved
This incident has been resolved.
Posted 8 months ago. Dec 01, 2018 - 11:56 UTC
Investigating
We are currently investigating the issue.
Posted 8 months ago. Dec 01, 2018 - 10:38 UTC
This incident affected: Address Validate (REST) v2.