Incident Notification - P2 - Higher than usual response time on EV Real Time (RT)

Incident Report for Experian Data Quality

Resolved

Response times have returned to normal and we are monitoring.
Posted Sep 23, 2025 - 10:52 UTC

Investigating

Some customers using Email Validate may have seen higher response times.
We are currently investigating the issue.
Posted Sep 23, 2025 - 09:57 UTC
This incident affected: Email Solutions (Email Validation).