Higher error levels for Email Validate and Intelligent Search

Incident Report for Experian Data Quality

Resolved

A fix has been implemented and we are monitoring closely
Posted May 07, 2025 - 21:45 UTC

Investigating

Some customers may be experiencing increased error levels. We are currently investigating
Posted May 07, 2025 - 17:00 UTC
This incident affected: Email Solutions (Email Validation, Experian Email Validation) and Other (IST Watch).