Incident Notification - Email Validation Real Time
Incident Report for Experian Data Quality
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 23:37 UTC
Investigating
We are currently investigating this issue.
Posted Apr 01, 2021 - 23:10 UTC
This incident affected: Email Solutions (Email Validation, Experian Email Validation).