Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2024 - 05:00 UTC
Scheduled
Scheduled Maintenance October 8, 2024 0500 – 0800 UTC
Please note that we are planning essential maintenance to the Experian Self Service portal. This will mean that it's inaccessible during the maintenance period.
We apologize for any inconvenience this may cause.
Please reach out to your local support teams if there are any questions
Posted Sep 05, 2024 - 18:18 UTC
This scheduled maintenance affected: Other (Self Service Portal).